+ Reply to Thread
Results 1 to 4 of 4

Thread: Ultimate DTT-880HD

  1. #1
    Albie
    Guest

    Default Ultimate DTT-880HD

    I got an Ultimate DTT-880HD off trademe, it looks to be a copy or OEM version of the eXtra Terrestrial STB (the manuals are similar, the firmware upgrade procedure is identical... down to the filename).

    Anyway, It worked for about a week, then my baby brother pressed a few buttons on the remote and it froze up... now it only displays the installation screen, pressing any buttons (either on the remote or the unit itself) does nothing, and the LCD panel on the unit just displays either AECt or RECt (the a and r look the same). when you turn it off at the wall, it displays the following series of things:
    ----
    boot
    CHEC
    boot
    AECt (or RECt)

    The guy i bought it off on trademe gave me a one year warranty (my guess is he's a one man band importer).. still waiting for his reply, but if i can do something to fix it, i'd rather that.

    Anyone have any experience with the Ultimate 880, or eXtra terrestrial and have any ideas how one might solve this problem?
    Last edited by Albie; 02-01-2009 at 05:28 PM.

  2. #2
    Super Moderator
    Join Date
    Nov 2007
    Location
    Apsattv
    Posts
    3,345

    Default

    It should have some sort of box reset procedure?

  3. #3
    Member
    Join Date
    Jun 2008
    Location
    Auckland
    Posts
    60

    Default

    It doesnt sound too good if the controls on the front dont work, but how about pulling the power plug out for around 10 minutes and then see if that resets it (dont just turn off the power switch on the back of the unit) - I have seen this method suggested as a reset.

    The other thing you might try is downloading the latest firmware (even if you have installed it) and trying the upgrade process - maybe the firware is a bit screwed up.

    If you dont get anywhere then try the geekzone forum:
    http://www.geekzone.co.nz/forums.asp...&topicid=24705
    The distributor is often available on there as well as lots of other owners of the ET box.

  4. #4
    Junior Member
    Join Date
    Nov 2018
    Location
    Half Moon Bay, Auckland
    Posts
    1

    Default

    Hi Albie, my freeview decoder is the same model as yours and got the same problem. Have you already fixed your decoder and how? Thanks.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts